Лучшие IT-решения для бизнеса

При реализации продукции предприниматели в обязательном порядке сталкиваются с потребностью в создании ценников. В типовой конфигурации 1С:Розница предусмотрен механизм оформления и распечатки для любой номенклатурной позиции, которая занесена в информационную базу. Перед началом подготовки ценника к печати заполните товарную номенклатуру в 1С: Розница 8.2. Убедитесь, что все товары, для которых вы создаете ярлыки, занесены в базу.

Подберем принтер для печати ценников на любой бюджет! Консультация и помощь 24 часа. Оставьте заявку и получите консультацию в течение 5 минут.

Печать ценников из документов поступления товаров

В обеих конфигурациях, и 1С Розница, и 1С Управление торговлей, для удобства пользователя реализована возможность печати ценников непосредственно из документов поступления товаров. Данная функция доступна в кнопке Печать, выбрав строку Ценники.

Пример печати ценников из документа Поступление товаров в конфигурации 1С Розница 2.2.

Пример печати ценников из документа Поступление товаров и услуг конфигурации 1С Управление торговлей 11.3.

Нажав на кнопку Печать — Ценники из документа вызывается обработка Печать ценников и в нее автоматически переносятся номенклатурные позиции из документа.

Пример заполнения табличной части обработки из документа в конфигурации 1С Розница 2.2.

Пример заполнения табличной части обработки из документа в конфигурации 1С Управление торговлей 11.3.

См. также:

  • Загрузка из Excel в 1С 8.3
  • Как выгрузить документ, отчет из 1С 8.3 в Excel
  • Сбилась нумерация документов в 1С 8.3: как исправить
  • Выгрузка в 1С из xml: как выгрузить данные из 1С 8.3 и загрузить в 1С 8.3
  • Дополнительные реквизиты и дополнительные сведения в 1С

Если Вы еще не являетесь подписчиком системы БухЭксперт8:

Активировать демо-доступ бесплатно →

или

Оформить подписку на Рубрикатор →

После оформления подписки вам станут доступны все материалы по 1С Бухгалтерия, записи поддерживающих эфиров и вы сможете задавать любые вопросы по 1С.

Помогла статья?

Получите еще секретный бонус и полный доступ к справочной системе БухЭксперт8 на 14 дней бесплатно

Шаблоны для печати ценников в 1С

За соблюдением стандартов оформления ценников следит Роспотребнадзор. При выявлении нарушений, например, размещение недостоверной информации о продукте, на предпринимателя накладываются штрафные санкции. Для ИП и должностных лиц полагается штраф в размере от 300 до 1500 рублей. Для организаций — 10 000-30 000 рублей.

Существуют два законодательных акта, на которые нужно ориентироваться при формировании ценников. Первый — Постановление Правительства РФ № 55 от 19.01.1998 г., второй — Закон о защите прав потребителей. Законодательство обязывает предпринимателей выставлять одинаково оформленные этикетки, в которых обязательно должно присутствовать наименование, стоимость за единицу (штуку, литр, килограмм и пр.). Дату назначения стоимости и подпись кассира или администратора сейчас указывать не обязательно. При этом вариант размещения может быть любым — бумажный носитель, электронное табло, стенд, держатель для ценников. Главное — обеспечить покупателю доступ к информации. Предприятиям, осуществляющим выездную торговлю, нужно позаботиться о составлении прайса. В нем необходимо указать наименование и стоимость продукции. Документ должен быть заверен печатью владельца торговой точки.

Подпишись на наш канал в Яндекс Дзен — Онлайн-касса!
Получай первым горячие новости и лайфхаки!

Если вы решили уценить изделие, зачеркивать стоимость и вписывать новую нельзя. Создайте новый бланк и наклейте его поверх прежнего.

Информация, которую должен указать сотрудник, представлена в таблице:

Печать ценников со штрихкодом в 1С: 8.3 Розница

Рассмотрим, как сформировать ценник со штрихкодом в 1С. Как правило, такой вид отсутствует в стандартных шаблонах типовой конфигурации, но его можно добавить. В начале установите специальную компоненту BarCode v8.0.15. и файл .epf.

Откройте программу 1С и перейдите в меню «Маркетинг». Кликните «Ценообразование», затем «Цены номенклатуры».

В открывшемся списке документов выберите тот, для позиций которого нужно напечатать ярлык. Выделите его, щелкнув левой кнопкой мыши (ЛКМ), нажмите на «Печать» и выберите операцию, которую желаете осуществить.

Далее откроется форма товаров из выбранного документа. Можно указать все или только отдельные позиции. Затем выберите макет, нажав «Установить» — «Шаблон ценников».

В открывшемся окне сформируйте новый шаблон. Укажите тип, задайте название, затем нажмите «Редактировать макет».

Чтобы не создавать его с нуля, воспользуйтесь уже готовым примером. Для этого щелкните «Загрузить шаблон по умолчанию» и из выпавшего списка выберите «Ценник».

Откроется стандартный пример без штрихкода. Обратите внимание на 6 строку, которая служит интервалом между параметрами. Выделите ее правой кнопкой мыши (ПКМ) и в контекстном меню примените команду «Раздвинуть».

Выполните эту операцию 3-4 раза, пока не появится достаточно пространства для вставки штрихкода. Установите курсор в последнюю свободную строку (например, 10) и из списка, расположенного в левом блоке, выберите «Штрихкод».

Появится диалоговое окно. Подтвердите команду вставки штрихкода.Он появится в поле, но будет сжат. Щелкните по нему ЛКМ и растяните по всему свободному пространству. Задайте количество экземпляров для вывода на принтер. Обычно на лист формата А4 помещается 8 ярлыков (2 по горизонтали и 4 по вертикали).

Вернитесь к форме печати ценника в 1С и выделите все товарные позиции. Далее кликните «Установить» — «Ценник». Готовые будут выглядеть так. На этом этапе их можно распечатать.

Подберем оборудование для печати ценников и этикеток. Доставим в любую точку РФ! Оставьте заявку и получите консультацию в течение 5 минут.

Как создать шаблон в 1С:8.3 Розница 2.2 для печати ценников

Запустите программу, перейдите в раздел «Администрирование». Нажмите на кнопку «Печатные формы, отчеты и обработки» и перейдите по ссылке «Шаблоны этикеток, ценников и чеков ККМ». В информационной базе уже присутствуют несколько вариантов, откройте папку «Шаблоны ценников для офисного принтера». Воспользуйтесь уже имеющимися или создайте новый, нажав соответствующую кнопку. Укажите тип и задайте ему наименование. Кстати, здесь же вы можете создать форму для распечатывания подарочного сертификата, дисконтной карты, регистрационной карты.

Далее кликните «Редактировать макет» и подтвердите сохранение введенных данных во всплывшем окне. В разделе редактирования образца введите все необходимые данные о товаре: наименование, производитель, код, артикул, цена за объем или штуку, единица измерения, штрихкод (если необходим). После этого нажмите «Ок» и подтвердите сохранение информации.Также вы можете воспользоваться готовыми макетами, сформировав на их основе новый, добавляя необходимую информацию о товаре. Например, штрихкод или логотип компании.

Перейдите в меню «Закупки» — «Сервис» — обработка «Печать ценников и этикеток». В открывшемся окне укажите магазин, для которого требуется печать ценников в 1С: 8.3 (если их несколько). Установите цены, выбрав текущую дату и параметр, по которому нужно их подобрать — «По состоянию» (будут указаны действующие или установленные цены) или «По виду цен» (дилерская, мелкооптовая, розничная, закупочная и прочие виды, которые присутствуют в информационной базе).

Далее установите режим — «Печать ценников». Подберите товары, нажав соответствующую кнопку. В открывшемся окне кликните по артикулу продукта, для которого желаете распечатать ярлык с ценой, и нажмите «Выбрать». Окно подбора закроется, а в разделе обработки появится новая строка с выбранной продукцией. Перед тем, как вывести ценник на печать в 1С:8.3 Розница 2.2, укажите их количество и примените шаблон, который создали ранее. Далее установите галочку «Выбран» и нажмите «Печать».

Печать этикеток в 1С

Создание этикеток выполняется в той же форме обработки. Добавьте товар из номенклатуры — «Подобрать товар», либо осуществите его отбор — «Показать отбор» (здесь вы можете отредактировать и выбрать нужные позиции). После этого щелкните «Заполнить» и выбранная продукция появится в форме обработки.

Далее кликните «Установить режим печати» и в выпавшем списке выберите нужную операцию. Если вы не создавали ранее макетов, система предложить сделать это сейчас. После подтверждения действия будет открыта форма редактирования макетов. Укажите тип и наименование.

Перейдите в редактор макетов и создайте новый, либо загрузите образец по умолчанию с помощью соответствующей команды. Обычно ярлык состоит из наименования и штрихкода. При необходимости отредактируйте макет (например, измените размер штрихового кода) и распечатайте его.

Сформировать этикетку для печати можно также из раздела «Поступление товара» программы 1С.

Шаблон ценника в 1С Розница 2.2

Посмотреть и настроить шаблон ценника можно в разделе Администрирование — Печатные формы, отчеты и обработки.

Перейдем по ссылке Шаблоны этикеток, ценников и чеков ККМ.

Здесь находятся шаблоны ценников и при необходимости мы можем создать (кнопка Создать) и разработать свой шаблон.

Откроем двойным щелчком мышки имеющийся шаблон (или создадим новый). Нажав кнопку Редактировать макет, можем изменить внешний вид нашего ценника — изменить шрифт, убрать или добавить какие то поля (например штрихкод).

Мы можем загрузить шаблон по умолчанию и на его основе сделать свой шаблон или импортировать уже готовый шаблон (кнопки Загрузить шаблон по умолчанию и Импортировать).

Используя доступные поля (слева) мы можем их добавлять их в шаблон.

Обратите внимание на значение полей Количество на странице. Здесь следует задать сколько ценников по горизонтали и по вертикали выводить на печать (в зависимости от размера вашего шаблона). Если этот параметр не задать, то по умолчанию будет печатать по одному ценнику на лист.

Создание и печать ценников в 1C:Бухгалтерия 8.3

Принцип создания и печати ценников в 1С:Бухгалтерия 8.3 такой же, как и рассмотренный ранее. Поэтому ниже мы расскажем о том, как распечатать ценник из товарной карточки.

Войдите в папку , после чего выберите строчку с нужным товаром, кликните на нее и нажмите . В появившемся окне, нужно выбрать один из существующих макетов или создать свой. Для этого укажите нужный тип, цену и количество. Добавьте в шаблон нужные строки, перетянув их из окна, расположенного в левой части монитора. Так можно добавить изготовителя, число, штрих-код, единицу измерения, налоговую ставку и другие. При необходимости, можно откорректировать любую ячейку.

Когда добавленные строки будут заполнены, можно откорректировать штифт и цвет текста, местоположение строк, после чего отправить макет в печать.

Печать ценников в конфигурации 1С: Бухгалтерия 8.3

Принцип печати ценников в 1С: Бухгалтерия 8.3 практически аналогичен тому, что был описан выше. Но мы дополнительно рассмотрим процесс, осуществляемый из номенклатурной карточки.

Откройте папку номенклатуры, в которой расположена нужная товарная позиция. Выделите ее и щелкните «Печать ценников и этикеток». В открывшейся форме примените существующий макет или создайте новый.

Введите параметры: тип цены и количество. Затем доработайте макет и добавьте в него нужные позиции, перетащив их из блока с левой стороны экрана. Например, артикул, единицу измерения, производителя, ставку НДС, текущую дату, штрихкод, объем.

При желании можете редактировать каждую ячейку. выделив ее и кликнув ПКМ. В открывшемся контекстном меню отредактируйте параметры размещения, положения, оформления. Можете поменять шрифт и цвет текста, выровнять его по вертикали или горизонтали. По окончании редактирования распечатайте документ.

Подключим онлайн-кассу к 1С за 1 час и 3000 ₽! Оставьте заявку и получите консультацию в течение 5 минут. Оцените, насколько полезна была информация в статье?

1С: Печать штрих кодов

Старый вариант печати штрих-кода в документах

ОбластьМакета = Макет.ПолучитьОбласть(«Заголовок»); ОбластьМакета.Рисунки.Штрихкод.Объект.ТипКода = 4; ОбластьМакета.Рисунки.Штрихкод.Объект.Сообщение = ПолучитьШтрихкодДокумента(Ссылка);

В итоге в документе будет выведен желаемый штрих-код.

Проблема, в режиме управляемого приложения вываливается ошибка:

ОбластьВывода.Рисунки.ШтрихКод.Объект – неопределено

Новый вариант печати штрих-кода через компоненту из макета

Дело в том, что для управляемого приложения внешние компоненты разрабатываются по другой технологии. Пример внешней компоненты для печати штрих-кода для управляемых форм есть в демонстрационной конфигурации «Управляемое приложение» в макетах справочника Товары, либо в конфигурации «1С:Управление торговлей» версии 11, макеты обработки «Печать этикеток и ценников».

Новую компоненту не надо вставлять непосредственно в макет печатаемого документа, надо передать ей строковое значение, в ответ она вернет штрих код в виде «картинки». Саму компоненту лучше загрузить компоненту в общий макет (в виде бинарных данных).

Сначала в макет вставляем обычную картинку:

Для картинки назначаем имя объекта «КартинкаШтрихкода»:

Далее надо получить объект внешней компоненты:

Функция ПодключитьВнешнююКомпонентуПечатиШтрихкода() Экспорт ПодключениеВыполнено = ПодключитьВнешнююКомпоненту(«ОбщийМакет.КомпонентаПечатиШтрихкодов», «КартинкаШтрихкода», ТипВнешнейКомпоненты.Native); // Создадим объект внешней компоненты Если ПодключениеВыполнено Тогда ВнешняяКомпонента = Новый(«AddIn.КартинкаШтрихкода.Barcode»); Иначе Возврат Неопределено; КонецЕсли; // Если нет возможности рисовать Если НЕ ВнешняяКомпонента.ГрафикаУстановлена Тогда // То картинку сформировать не сможем Возврат Неопределено; Иначе // Установим основные параметры компоненты // Если в системе установлен шрифт Tahoma Если ВнешняяКомпонента.НайтиШрифт(«Tahoma») = Истина Тогда // Выбираем его как шрифт для формирования картинки ВнешняяКомпонента.Шрифт = «Tahoma»; Иначе // Шрифт Tahoma в системе отсутствует // Обойдем все доступные компоненте шрифты Для Сч = 0 По ВнешняяКомпонента.КоличествоШрифтов -1 Цикл // Получим очередной шрифт, доступный компоненте ТекущийШрифт = ВнешняяКомпонента.ШрифтПоИндексу(Сч); // Если шрифт доступен Если ТекущийШрифт <> Неопределено Тогда // Они и будет шрифтом для формирования штри-кода ВнешняяКомпонента.Шрифт = ТекущийШрифт; Прервать; КонецЕсли; КонецЦикла; КонецЕсли; // Утановим размер шрифта ВнешняяКомпонента.РазмерШрифта = 12; Возврат ВнешняяКомпонента; КонецЕсли; КонецФункции

В первой строке функции компонента загружается из макета, далее заполняются параметры и возвращается объект компоненты. Затем опишем функцию, которая, получив данные, сформирует нужную нам картинку с штрихкодом:

Функция ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода) Экспорт ВнешняяКомпонента = ПодключитьВнешнююКомпонентуПечатиШтрихкода(); Если ВнешняяКомпонента = Неопределено Тогда ВызватьИсключение НСтр(«ru = ‘Ошибка подключения внешней компоненты печати штрихкода!'»); КонецЕсли; // Зададим размер картинки ВнешняяКомпонента.Ширина = Окр(ПараметрыШтрихкода.Ширина); ВнешняяКомпонента.Высота = Окр(ПараметрыШтрихкода.Высота); ВнешняяКомпонента.АвтоТип = Ложь; ВнешняяКомпонента.ТипКода = ПараметрыШтрихкода.ТипКода; ВнешняяКомпонента.ОтображатьТекст = ПараметрыШтрихкода.ОтображатьТекст; ВнешняяКомпонента.РазмерШрифта = ПараметрыШтрихкода.РазмерШрифта; // Или установим код EAN-13 // ВнешняяКомпонента.ТипКода = 1; // // Тип смотрим в документации на внешнуюю компоненту // Если код содержит контрольный символ, обязательно указываем ВнешняяКомпонента.СодержитКС = СтрДлина(ПараметрыШтрихкода.Штрихкод) = 13; // Если отображать контрольный символ не нужно // ВнешняяКомпонента.ВидимостьКС = Ложь; // Формируем картинку штрихкода ВнешняяКомпонента.ЗначениеКода = ПараметрыШтрихкода.Штрихкод; // Если установленная нами ширина меньше минимально допустимой для этого штрихкода Если ВнешняяКомпонента.Ширина < ВнешняяКомпонента.МинимальнаяШиринаКода Тогда ВнешняяКомпонента.Ширина = ВнешняяКомпонента.МинимальнаяШиринаКода + 10; КонецЕсли; // Сформируем картинку ДвоичныеДанныеКартинки = ВнешняяКомпонента.ПолучитьШтрихкод(); // Если картинка сформировалась Если ДвоичныеДанныеКартинки <> Неопределено Тогда // Формируем из двоичных данных Возврат Новый Картинка(ДвоичныеДанныеКартинки); КонецЕсли; Возврат Неопределено; КонецФункции

ТипКода — число от 0 до 15: 0 — EAN8, 1 — EAN13, 2 — EAN128. Вот полный список типов по порядку:

Кроме типа штрихкода, компонента имеет ряд других свойств, например ВнешняяКомпонента.ОтображатьТекст, ВнешняяКомпонента.РазмерШрифта и прочие, можно посмотреть в свойствах.

Наконец последнее, получаем и выводим штрихкод в картинку:

Эталон = ПолучитьОбщийМакет(«Эталон»); КоличествоМиллиметровВПикселе = Эталон.Рисунки.Квадрат100Пикселей.Высота / 100; ПараметрыШтрихкода = Новый Структура; ПараметрыШтрихкода.Вставить(«Ширина», Окр(ОбластьМакета.Рисунки.КартинкаШтрихкода.Ширина / КоличествоМиллиметровВПикселе)); ПараметрыШтрихкода.Вставить(«Высота», Окр(ОбластьМакета.Рисунки.КартинкаШтрихкода.Высота / КоличествоМиллиметровВПикселе)); ПараметрыШтрихкода.Вставить(«Штрихкод», ?(ЗначениеШК=»»,СокрЛП(ЧисловойКодПоСсылке(Ссылка)), ЗначениеШК)); ПараметрыШтрихкода.Вставить(«ТипКода», 4); // Code128 ПараметрыШтрихкода.Вставить(«ОтображатьТекст», Ложь); ПараметрыШтрихкода.Вставить(«РазмерШрифта», 6); ОбластьМакета.Рисунки.КартинкаШтрихкода.Картинка = ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода); ТабличныйДокумент.Вывести(ОбластьМакета);

Макет «Эталон» необходим для точного расчета размеров картинки. В итоге в области макета появится штрих код, окончательный вид сформированного документа:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *